您的位置 首页 未分类

网络工程师成长日记413-长安大学交换机项目

网络工程师成长日记413-长安大学交换机项目 这是我的第413篇原创文章,记录网络工程师行业的点点滴滴,结交IT行业有缘之人   长安大学 这周我们主要做长安大学渭水校区的学生公寓交换机的堆叠拆分和重新堆叠…

网络工程师成长日记413-长安大学交换机项目

这是我的第413篇原创文章,记录网络工程师行业的点点滴滴,结交IT行业有缘之人
 网络工程师成长日记413-长安大学交换机项目 - 1
长安大学
这周我们主要做长安大学渭水校区的学生公寓交换机的堆叠拆分和重新堆叠(堆叠交换机为S2126、S2150)。
每栋楼的交换机有不等台S2126、S2150组成,其中堆叠时最好相同型号的交换机进行堆叠。
渭水校区学生公寓拓扑图:
网络工程师成长日记413-长安大学交换机项目 - 2
拆分堆叠和重新堆叠主要步骤:
说明:在做网路之前,首先熟悉网路设备的拓扑及其他相关信息。
学校的李老师说他们学校有个vlan 13是用来接专网所用,可以用此vlan 来对学生公寓进行检测。
所以每此重新堆叠时需要查看vlan 13 在主交换机上还是副交换机上。
第一步:
删除交换机上原有的配置,删除配置后重新启动交换机,注意不要重新启动不要保存。具体配置命令:
#delete flash:config.text 。
#reload
第二步:
然后就关闭电源,进行重新堆叠。
注意堆叠的线序,接成菊花形状,up接口接down。
然后加电启动,查看堆叠,如果堆叠成功就在主机上开始配置。
把编辑好的文档复制到全局模式下。
#show member
#config
# hostname 7#73       //主机名有学生公寓和主辅交换机而定。
vlan 1
exit
vlan 13              // 用来专用网接入,管理和查看学生公寓网络状况
exit
vlan 3370
exit
ip access-list extended 100
  deny tcp any  any eq 445
  deny udp any  any eq 445
  permit ip any  any
exit
radius-server host 172.19.104.3
aaa authentication dot1x
aaa accounting server 172.19.104.3
aaa accounting
aaa accounting update
enable secret level 1 0 密码不能公开
enable secret level 15 0 密码不能公开
port-security arp-check cpu
service dhcp
ip helper-address 10.1.1.2            //配置DHCP Server 的IP地址
ip dhcp relay information option dot1x//设置DHCP option 82信息是基于802.1x的信息
spanning-tree mode rstp    //设置生成树协议为快速生成树Rstp
spanning-tree
interface vlan 1
 no shutdown
 ip address 172.19.104.73 255.255.255.0  // 新换的管理ip地址与公寓号对应
exit
dot1x client-probe enable
dot1x probe-timer alive 250
aaa authorization ip-auth-mode dhcp-server
dot1x accout-update-interval 3600
radius-server key 密码不能公开
dot1x authentication ipv6 enable
ip default-gateway 172.19.104.254      // 配置的默认网关
snmp-server community 密码不能公开 rw
cpu topology-limit 75
  errdisable recovery interval 1800
第三步:
配置各端口并划分到vlan 3370,根据交换机的具体情况而定。
#interface range fastEthernet 1/0/1-23,2/0/1-24,3/0/1-24,4/0/1-24,5/0/1-24
 switchport access vlan 3370
 spanning-tree bpduguard enabled
 dot1x port-control auto
 ip access-group 100 in
exit
第四步:
在接口上配置trunk,在此之前show vlan信息,配置好后测试网络状况
ping172.19.104.254等。然后保存配置。
#interface f 1/0/24
switchport mode trunk
如果把接口换分到vlan中
#config
#interface f1/0/24
#switchport access vlan 13
#exit
#ping 172.19.104.254
#write
项目总结:
通过此次的项目使我对交换机的堆叠更加清楚和明白,巩固了堆叠方面的知识,熟悉了交换机的堆叠过程。
我发现看再多遍的书,还不如自己亲手动手实验一边,宁可在实验过程中出错,也比再工程项目上出错要好的多。
发现错误,及时去分析查找情况,然后再排除错误。
这样知识才会积累,经验才会增长。
在周一到周四早上的实施过程中基本上没什么问题。
但是在下午即将对十二号楼做堆叠时,发现交换机堆叠不起来,然后我们用命令进行检测(show logg)发现堆叠丢失。
我们对问题进行了详细分析,有几种可能性:
第一,堆叠模块损坏;
第二,堆叠线有问题;
第三,堆叠交换机之间版本不一致;
第四,交换机出现问题。
我们换了堆叠模块和堆叠线,发现依然不能堆叠,可以排除模块和线的损坏,接着对版本不一致的交换机进行了版本升级
发现依然不能堆叠,则说明不是版本问题,就有可能是交换机问题。
也因为设备还不够等原因,我们只能等到下周再去处理堆叠问题。
本文是网络工程师成长日记(www.xacisco.net)原创文章,不授权任何个人和商业组织转载https://www.xacisco.net/3232

作者: admin

网工记小编 老郑  思科认证网络专家CCIE13155 微软全球最有价值专家MVP 微软认证系统专家MCSE,微软认证数据库专家MCDBA 通信技术讲师,motorola认证2G,3G技术讲师,nokia认证2G,3G技术讲师 网工记网站创始人,网工记实验室创始人,onelab网络实验室创始人

我要吐槽:

联系我们

联系我们

13810168532

在线咨询: QQ交谈

邮箱: 20004@163.com

工作时间:周一至周五,9:00-17:30,节假日休息

关注微信
微信扫一扫关注我们

微信扫一扫关注我们

关注微博
返回顶部