首页 » 网络工程师成长日记 » 网络工程师成长日记347-某卷烟厂工程

网络工程师成长日记347-某卷烟厂工程

发布日期:2018-12-05

浏览:52次

网络工程师成长日记347-某卷烟厂工程

这是网络工程师成长日记的第347篇连载文章,记录网络工程师行业的点点滴滴,结交IT行业有缘之人
 网络工程师成长日记347-某卷烟厂工程插图
早上正沉浸在老大的OSPF技术中,突然被告知要去旬阳做项目,又惊又喜。
我和吴工跟着老大去货源提了货,便匆忙搭上去火车站的公车。
车上大概了解了一下这次项目的内容,某卷烟厂的设备陈旧,需要更换一台路由器
我们的工作就是带着这台价值35000RMB的cisco c3825去给他们换上,并保证网络平滑过渡,类似于“割接”,但其实要简单得多。
中午12点多的火车,我们粗略估算了一下时间,计划着速战速决,晚上就回来。
11月份并不是返乡高峰期,但火车站的民工队伍确实让我们吃了一惊。
好不容易被人流挤进了站,爬上了车,火车却迟迟不开。
后来一打听才知道,人太多了,半天上不完,8节硬座车厢挤了2300多人…
当时对这个数字没概念,后来才知道每节硬座车厢的标配是120座……还好我们是卧铺。
这条线要过秦岭,一路上除了隧道还是隧道
照吴工的话说“我睡的时候在隧道里,一觉醒来还在隧道里……”。
吴工超可爱,跟他聊天很有意思,太好玩了。
我没有睡,可能是因为心情激动吧,思维很活跃,一路上乱七八糟的想,想象工程现场的机柜林立,想象一排排强大的高端设备,想象一张张庞大的拓扑图(你想,烟厂啊,有钱单位)……
当然还得想想自己几斤几两,难免还是有点小紧张。
尽管隧道众多,但有时也是能看见风景的。
秦岭以北到处是白茫茫的一片,一马平川,白雪皑皑,相当壮观。过了秦岭以后,气温明显要高一些,不但没有积雪,连树都是绿的。特别是到了一个叫“小河镇”的地方,真的到处都是小河,那叫一个青山绿水世外桃源啊。
你想象过你家别墅一出门就是开阔的石滩,美丽的大湖,并且湖对面就是幽幽的青山吗?来小河镇吧。
火车毫无悬念的晚了点,到站已经5点半,用脚指头想也知道今晚回不去了。
如意算盘落空,三个人还是有一丝失落,不过转瞬即逝,因为客户说要请吃饭,这对坐了一下午火车的我们,特别是一口气吃了两碗泡面还喊饿的老大来说是相当诱惑的。
对方没有来接,我们自己从某北站打了车去县城,司机是个很搞笑的女人,一路跟老大聊的不亦乐乎,最后还聊成了老乡,虽然车费一分没少,但某人的朴实热情给人一种亲切的感觉。
接应我们的是这次项目的边缘人“陈工”,白白胖胖文质彬彬的样子。
陈工给我们安排了住处,随后带我们去了一家火锅店见客户。
本来以为就是吃个便饭,交流一下工程方面的事情,没想到气氛远没有想象中轻松。
进了包厢只见一个深沉的中年男人在主位上翘着二郎腿,嘴角叼着一根烟。
从他指甲的发黄程度来看,烟龄应该在20年以上。
不知道是对方的问题还是我们的问题,一开始气氛竟有些尴尬。
后来老大悄悄告诉我,那个人是卷烟厂信息技术部的副科长,可能嫌来的人多了,而且看着太年轻不像工程师。
这种情况很危险,如果客户知道我跟吴工是实习学生的话肯定会很不高兴,合作不愉快的话下次再合作就很难了,而且中间的货源网络和陈工也会很难做,处理不好要伤和气。
但这种事其实也简单,特别是在饭局上,当我看见桌上的两瓶52度“杜康窖藏”,我笑了。
好歹我曾在五星级酒店做过半年人力资源,这种场合是家常便饭了。
在HR别的没学会,待客之道倒是耳濡目染了一些。
尽管从福建回来已经戒了酒,但这种情况也只好故技重施,反客为主了。
等所有人坐定我便主动展开攻势,从程科长开始一轮轮的敬酒,还好对方也比较朴实,不然我那些蹩脚的说辞是混不过去的。
酒过三巡,程科长也笑了。
[图1 秦岭以北的地方,还未到秦岭。]
网络工程师成长日记347-某卷烟厂工程插图1
[图2 隔着窗户拍的,效果不太好。]
网络工程师成长日记347-某卷烟厂工程插图2
这里面有两个人不得不提,一个是老大,一个是陈工的老婆。
看似是我在场上忙来忙去,其实真正撑场面的人是老大,说话谦虚谨慎,不温不火,反应机敏,应对自如。
明眼人都看得出我们这三人到底谁说了算。唉,说来说去,姜还是老的辣。
陈工比较木讷,但他有个很强的老婆。
陈夫人27,8的样子,颇有几分姿色。
这个女人心思缜密,处事圆滑,很会说话。
最关键的是她充分发挥了女人温柔贤惠的优势,哄得程科长很是高兴。
吃完饭,大家都挺满意,约定了第二天见面的时间地点就各自散了。
旅店环境还不错,至少干净。只是我因为吃了辣又喝猛了酒,胃难受了一晚上。
本以为做了技术就不用再应付这样的场合,现在看来,干哪一行都不是那么容易的。
老大一直在查3825的资料,据说是因为他之前也没碰过这个型号。
老大说cisco的设备太多了,出来做工程经常会碰到一些陌生的设备,你必须事先做好充分的准备,到时候才能应对自如。
他一边查一边给我们讲这台路由器的相关信息。很强大,至少我这么觉得。
一夜无话。由于卷烟厂只能在中午吃饭时间,也就是网络使用率最低的时候才能把网络中断一会儿,所以我们一觉睡到第二天9点。
陈工来交代了些事就忙自己的去了。
我们三个搭车到了某卷烟厂,扑面而来尽是烟草的香味。
某卷烟厂是宝鸡卷烟厂的分厂,厂子很大,四面环山,环境很好,到处种着一种他们当地特产的橘柑,我们还尝了两个,闻起来有股淡淡的清甜的香味,吃起来有点苦,但据说能去火。到信息技术部找到了程科长,他带我们进入了这家企业的网络核心地带,机房。场面比想象中要逊色一些,没有林立的机柜,也没有庞大的拓扑,但就是这简单的网络结构支撑着整个某卷烟厂的通讯。
程科长带我们看了设备,指着一台cisco c3640说就是要换它。
沟通清楚以后程科长去忙别的事了。
老大带着我们分析面前的设备,有很多不认识的,很多老大讲了我也不明白是什么东西的,还有很多闲置的设备,都是接好的,但根本没用,有钱单位就是牛。
其实网络拓扑很简单,一眼就能看出来,信息需要保密,不便多说。
检查完设备我们开始配置这台被我一路从西安扛过来的路由器,拆封的一瞬有点不舍,毕竟我抱着它跑了那么远,都有感情了。Cisco c3825的庐山真面目还是没有让我失望,有3个大插槽,6个小插槽,支持VPN、QOS、VOICE,还有内置防火墙。两个千兆以太网口,并且每个插槽还可支持多个快速以太网接口、时分多路复用(TDM)互联,以及对于802.3af以太网电源(PoE)的全面集成配电等的带宽要求。它支持现有的模块化接口系列,这确保了持续投资的潜力,可以在部署新服务和应用时轻松实现网络扩展或技术变动。通过把多个独立设备的功能集成入单一小巧设备之中,Cisco c3825大幅降低了管理远程网络的成本和复杂度。
总之就是很强大。
[图3 传说中的cisco c3825]
网络工程师成长日记347-某卷烟厂工程插图3
首先我们telnet旧的cisco c3640查看并下载了配置,接下来只需要给新的3825换上插槽,把原有配置稍做修改后导入即可。现在看来真的是再简单不过了,但就是这么简单的事在当时却感觉那么陌生,甚至有些不知所措,不知道从哪做起。还是缺乏经验。在老大的指导下我们顺利完成了配置,可就在这时,却出现了一个异常现象。这台新的3825在配置过程中不断的弹出一个错误消息,看了半天也没看明白怎么回事,上网一查原来是一个关于硬件问题的错误信息,第三台风扇转速过低!!!
新设备怎么会出现这样的问题?
设备已经搬过来了,出现这样的问题该怎么办?
一大堆的问题扑面而至,气氛陡然紧张起来。我们赶快上网搜索解决办法,但没有一个满意的答案,关键时刻还是只能靠自己。
老大当机立断,修!
由于我们要瞒着客户,并且涉及保修问题不能在新设备上留下拆过的痕迹,这个修理过程进行的异常辛苦。中途工作人员突然进来好几次,我们只能停下,装作在配路由器。
我们利用了一切手头上能用的工具,打开了路由器,查出了问题,原来那台风扇的电源线松动了,根本不转。
把线接上,迅速原封不动似的装好,这才长长出了一口气。再次登录路由器,确保一切正常之后,悬着的心总算放下了。
要知道,新设备出了这样的问题是致命的,如果被客户发现很有可能要求退货,拒付货款。
真没想到一次简单的工程会出现这么个插曲,真是惊心动魄。
中午12点半,程科长那边暂时中断了网络,我们顺利的拆下了老设备,换上了新设备,在调试的过程中又出现了问题,4个串口都配置好了,但只起来了一个,其他3个无论我怎么搞就是不起来,又把我整紧张了。
还好老大经验丰富,到机柜后面检查了线路,发现其他3个串口连接的接口转换器根本没开……
一切都OK了,客户很满意,热情的请我们吃了午饭。下午老大给员工做了简单的培训,我们便欣然离开。
出了卷烟厂,感觉一身轻松,即便是这样一个简单的工程也让我学到了很多很多东西。这些宝贵的经验是永远无法在课堂上学到的,只有亲身经历才能体会到更加深刻的东西。
经过这次实战,我更加认识到实验的重要性。实验是理论的依托,没有实验,理论根本无法成立。多敲实验首先可以让我们熟练对设备的操作,其次可以验证理论的正确性,从而更加深入的理解原理。
俗话,说的多不如做的多,这是对的。
还有一点感触就是现在的大学生在学校太久,一毕业突然转向社会肯定会很不适应,所以应当提前做好准备,多接触社会,了解社会。
所谓知己知彼,百战不殆。多学点东西,总是没坏处的。
累了一天,回到西安已经是晚上10点多了,但三个人精神依然振奋(我怀疑是因为在车上打牌他俩把我赢爽了)。
出站时闻到空气里弥漫的汽车尾气的味道,居然如此的亲切。夜西安,美。
发几张照片:
晚上10点多在西安火车站,出站的一个女孩儿帮忙照的,老大把人家吓坏了……
某烟厂技术文档-伍鹏
一:情况描述
   主要就是把他们以前的cisco3640的路由器换成cisco3825系列路由器。配置不用做变化,简单的导出导入即可。等到他们员工吃饭时间做一下割接。就Ok了。
   二:网络拓扑
   去他们的机房看了看,设备很多,但主要的就是一个光端机,一个协议转换器,一台路由器,两台交换机,接下来就是接PC了。
三:配置文件
XY_C3825#show running-config
Building configuration…
Current configuration : 1573 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XY_C3825
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$Ig4L$Nx.SAJzK4ouZkfh6qrusQ0
!
no aaa new-model
!
ip source-route
ip cef
!
!
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface Multilink1
 ip address 10.155.99.22 255.255.255.252
 no cdp enable
 ppp multilink
 ppp multilink group 1
!
interface Gigabit
 ip address 10.155.77.29 255.255.254.0
 no ip mroute-cache
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
!
interface Serial1/0
 description to Baoji_yanchang
 bandwidth 2048
 ip address 10.155.73.2 255.255.255.248
 encapsulation ppp
 fair-queue
!
interface Serial1/1
 description to XA_AR46
 bandwidth 2048
 ip address 1.1.1.2 255.255.255.0
 fair-queue
!
interface Serial1/2
 description to XA_AR46
 bandwidth 2048
 no ip address
 encapsulation ppp
 fair-queue
 ppp multilink
 ppp multilink group 1
!
interface Serial1/3
 description to XA_AR46
 bandwidth 2048
 ip address 1.1.1.3 255.255.255.0
 fair-queue
!
ip forward-protocol nd
ip route 10.0.0.0 255.0.0.0 10.155.73.1
ip route 192.0.0.0 255.0.0.0 10.155.73.1
!
!
ip http server
!
snmp-server community public RO
!
!
control-plane
!
!
line con 0
 login
line aux 0
line vty 0 4
 password ANKANG_XYYC
 login
 transport input telnet
!
scheduler allocate 20000 1000
end
XY_C3825#SHOW IP INT BRI
Interface                  IP-Address      OK? Method Status                Prot
ocol
GigabitEthernet0/0         10.155.77.29    YES NVRAM  down                  down
GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down
Serial1/0                  10.155.73.2     YES NVRAM  down                  down
Serial1/1                  1.1.1.2         YES NVRAM  down                  down
Serial1/2                  unassigned      YES NVRAM  down                  down
Serial1/3                  1.1.1.3         YES NVRAM  down                  down
Multilink1                 10.155.99.22    YES NVRAM  down                  down
四:小问题
XY_C3825#
*Nov 19 03:23:46.707: %FAN-3-FAN_FAILED: Fan 3 had a rotation error reported.
*Nov 19 03:24:06.707: %FAN-3-FAN_FAILED: Fan 3 had a rotation error reported.
*Nov 19 03:24:26.707: %FAN-3-FAN_FAILED: Fan 3 had a rotation error reported.
*Nov 19 03:24:46.707: %FAN-3-FAN_FAILED: Fan 3 had a rotation error reported.
//这个就是在配置的过程中,发现cisco3825路由器第三个风扇不转,一直弹出这样的错误日志。
最后把路由器打开把线重新压了下,问题解决。原来是线松动了。
总结:通过这次和老大出去,虽然是一个很小的工程,但是还是让我深深感觉到了实践和理论的太大区别,知道我们学习这个,对动手能力和自学能力的要求是很高的。

本文出自 网络工程师培训、思科认证、华为认证培训-onelab网络实验室 ,原文链接:https://www.xacisco.net/4494 。如若转载请注明出处。

网络工程师成长日记500-30岁学华为云计算是个明智的决定吗

网络工程师成长日记500-30岁学华为云计算是个明智的决定吗

您现在看到的是网络工程师成长日记,记录网络工程师,日常生活点点滴滴   有个朋友和我微信沟通了很长时间, …

2020-12-08

网络工程师成长日记444-老板是最大的销售

网络工程师成长日记444-老板是最大的销售

老板是企业最大的销售,这句话我一直铭刻在心,很简单,因为当你记住这句话,一切的问题,团队的一切的问题,公司 …

2019-11-17

网络工程师成长日记443-多从局外人的角度观察,也许能找到答案。

网络工程师成长日记443-多从局外人的角度观察,也许能找到答案。

下午的时候,一个合作公司的老总打电话给我,说了一件这样的事情,实际上他的观察也对,而且这个问题我反映过多次 …

2019-11-14

特色专栏:

联系我们

咨询华为认证培训,思科认证培训,微信添加:

微信咨询:hi20004 (可手动添加咨询)